Thursday, October 20, 2016

Java Loops II

Hacker Rank Challenge
We use the integers , , and to create the following series:



You are given queries in the form of , , and . For each query, print the series corresponding to the given , , and values as a single line of space-separated integers.

Input Format
The first line contains an integer, , denoting the number of queries.
Each line of the subsequent lines contains three space-separated integers describing the respective , , and values for that query.

Output Format
For each query, print the corresponding series on a new line. Each series must be printed in order as a single line of space-separated integers.
Sample Input
2
0 2 10
5 3 5
Sample Output
2 6 14 30 62 126 254 510 1022 2046
8 14 26 50 98

JAVA Code

import java.util.*;
import java.io.*;
import java.lang.Math.*;

class Solution{
    public static void main(String []argh){
        Scanner in = new Scanner(System.in);
        int t=in.nextInt();
        int j;
        for(int i=0;i<t;i++){
            int a = in.nextInt();//initial value
            int b = in.nextInt();
            int n = in.nextInt();//sequence number
            int arr[]=new int[n];
            for(j=0;j<n;j++)
                {
                  int temp=a;
                 for(int inc=0;inc<=j;inc++)
                     {
                     temp=temp+(int)(Math.pow(2,inc)*b);
                     }
                  arr[j]=temp;
            }
            for(j=0;j<n;j++)
                {
                System.out.print(arr[j]+" ");
            }
            System.out.println();
        }
        in.close();
    }
}






Explanation:

We have two queries:
  1. We use , , and to produce some series :


    ... and so on.
    Once we hit , we print the first ten terms as a single line of space-separated integers.
  2. We use , , and to produce some series :




    We then print each element of our series as a single line of space-separated values.