In Python, a string can be split on a delimiter.
Example:
You are given a string. Split the string on a
Input Format
The first line contains a string consisting of space separated words.
Output Format
Print the formatted string as explained above.
Sample Input
Example:
>>> a = "this is a string"
>>> a = a.split(" ") # a is converted to a list of strings.
>>> print a
['this', 'is', 'a', 'string']
Joining a string is simple: >>> a = "-".join(a)
>>> print a
this-is-a-string
Task You are given a string. Split the string on a
" "
(space) delimiter and join using a -
hyphen. Input Format
The first line contains a string consisting of space separated words.
Output Format
Print the formatted string as explained above.
Sample Input
this is a string
Sample Output this-is-a-string
Python 3.0 Code:
inputsplit=input().split()
output="-".join(inputsplit)
print(output)